Back to overview
Resolved

Service interruption: MyDentalPractice app

Aug 3, 2026 at 11:37am UTC
Affected services
MyDentalPractice App

Resolved
Aug 3, 2026 at 11:50am UTC

Resolved. Sign in is working normally again. The security check no longer blocks users when it cannot complete because of a slow or interrupted connection. If you were affected, please sign in as usual. No patient data was affected. You can resume normal use of MyDentalPractice app (Sign in).

Created
Aug 3, 2026 at 11:37am UTC

We are investigating an interruption affecting MyDentalPractice app (Sign in). Some users cannot sign in. They see a message that the security check failed. Users who are already signed in can continue to work. Patient records are not affected and no data is lost. We are working to restore normal service as quickly as possible.