Emergency maintenance: MyDentalPractice app
Resolved
Jul 20, 2026 at 9:57pm UTC
Resolved. The maintenance is complete and the app is fully available. You can resume normal use. You can resume normal use of MyDentalPractice app (Platform).
Affected services
Updated
Jul 20, 2026 at 9:57pm UTC
Maintenance ended
Affected services
Created
Jul 20, 2026 at 9:37pm UTC
We are applying a small platform update that prepares sign-in links for the upcoming mobile apps. The app will be briefly unavailable while the update is applied and the service restarts. This maintenance was not scheduled in advance. Expected duration: up to 20 minutes. Affected: MyDentalPractice app (Platform).
Affected services