Back to overview
Resolved
Emergency maintenance: MyDentalPractice app
Jul 8, 2026 at 12:52pm UTC
–
Jul 8, 2026 at 1:12pm UTC
Affected services
MyDentalPractice App
Resolved
Jul 8, 2026 at 1:12pm UTC
Resolved. The camera now works when taking a patient photo during registration. You can resume normal use of MyDentalPractice app (Patient registration).
Affected services
Updated
Jul 8, 2026 at 1:12pm UTC
Maintenance ended
Affected services
Created
Jul 8, 2026 at 12:52pm UTC
We are applying a brief update to restore the camera when taking a patient photo during registration. The app will be briefly unavailable while the update is applied and the service restarts. Expected duration: Up to 20 minutes.. Affected: MyDentalPractice app (Patient registration).
Affected services